设为首页收藏本站|繁體中文

Project1

 找回密码
 注册会员
搜索
查看: 6467|回复: 29

[原创发布] 【8.18】该来的终于来了!伪网游系统初代版发布!

[复制链接]

TA还没有解放自身的潜力。

Lv1.梦旅人

梦石
0
星屑
50
在线时间
127 小时
注册时间
2014-2-22
帖子
233
发表于 2014-8-18 19:21:17 | 显示全部楼层 |阅读模式
为什么叫做初代版,是因为各种未知BUG我已经无力调试了…………

好吧上一次我开的征集帖写的是“八月初”发布,结果因为各种拖稿各种懒拖到了今天才刚刚做出来(刚才还混B站又拖了两个小时)
此版本号为1.0.0.1,提供了…………我也不知道多少个接口,反正列一遍就好:
以下是dll接口列表

.子程序 LoginFTP, 逻辑型, 公开, 一种可行的连接方式,正式版中均使用此版本
.参数 password1, 整数型

.子程序 Cloudstorage, , 公开, 存储单个文件的接口,无参数

.子程序 UseLogin, 整数型, 公开, 玩家登陆接口,供内置登陆窗口使用
.参数 name, 文本型
.参数 password, 文本型

.子程序 Updata, 逻辑型, 公开, 升级程序启动

.子程序 WindowsUserLogin, , 公开, 外置登陆窗口调用

.子程序 Logout, , 公开



因为其中一个插件因为文件名报毒,目前正在紧急抢修中…………

使用方法:
1.准备一个空间(该步骤详细等明天,今天实在无力写了)
2.把PseudoOnlineGameModule.dll放到游戏根目录下(根目录是哪里呢,就是和Game.rvproj2、game.exe同一个地方)
3.在main前调用LoginFTP,在main后调用Logout
4.在适当的位置使用其他函数

什么?你要详细教程?大神请饶了我吧……………………

连吐槽也不想发了,直接丢东西跑路,如果以后你们在B站看见一个叫零空的家伙,那一定是我………………

初代版功能较少而且效果挺差的………………比当初说的四五个功能还要少很多………………不过今后慢慢处理,总会有一年(?)能完成的吧……………………

空间教程:
1.注册一个空间
网上的各种免费空间很多,一搜就是一大把:
part1.jpg
我个人推荐的是这个空间,主要是界面比较直观,而且还算可以,还送域名。虽然服务器比较远,延时基本在3000ms+,但是做这个伪网游基本够用(要想做即时网游,不掏钱就甭想了)
跟着教程走,不到半个小时就差不多了。我这里就不多讲了,毕竟不太合主题。

2.添加账户
打开以后是这样的:
part2.jpg
虽然添加管理员账户和添加FTP账户都能登入FTP管理,但是建议还是创建FTP账户,防止被盗后造成不良影响
下载地址购买后可见,一次购买,终身免费(包含所有版本的下载地址)
(50经验,登陆一天就回来了,回十个贴就回来了,这终身免费呢)
8.22 重大问题
昨天我翻了翻,发现…………我tm没有放FTP账户文件的生成器…………赶紧连做,,今天特意补档:
FTP用户信息生成器.zip (1.16 MB, 下载次数: 123)
很多年了呢,坑还是没填完…………(草

TA还没有解放自身的潜力。

Lv1.梦旅人

梦石
0
星屑
50
在线时间
127 小时
注册时间
2014-2-22
帖子
233
 楼主| 发表于 2014-8-18 19:24:36 | 显示全部楼层
本帖最后由 1003492579 于 2014-8-18 19:27 编辑

此楼用于各种BUG,兼容性及其他技术性问题的综合楼
已知兼容的系统版本:
windows XP SP2/SP3
已知不兼容的系统版本:
MAC OS全系列
可能不兼容的系统版本:
windows 8/8.1
已知BUG:

欢迎大家在此楼回复提交意见\建议

点评

楼主你把linux扔到哪里去了。。。气哭  发表于 2015-2-3 19:00
加不了楼主Q。。and 上面那么多接口怎么弄  发表于 2014-8-20 18:56

评分

参与人数 1星屑 +15 收起 理由
落月小天魔 + 15 俺只能+15

查看全部评分

很多年了呢,坑还是没填完…………(草
回复 支持 反对

使用道具 举报

TA还没有解放自身的潜力。

Lv1.梦旅人

梦石
0
星屑
50
在线时间
127 小时
注册时间
2014-2-22
帖子
233
 楼主| 发表于 2014-8-18 19:34:08 | 显示全部楼层
很多年了呢,坑还是没填完…………(草
回复 支持 反对

使用道具 举报

TA还没有解放自身的潜力。

Lv1.梦旅人

梦石
0
星屑
63
在线时间
585 小时
注册时间
2013-5-25
帖子
1524
发表于 2014-8-18 19:39:58 | 显示全部楼层
辛苦了,我忘了我为什么要付给你50exp了怎么办

1.准备一个空间(该步骤详细等明天,今天实在无力写了)
↑暂时咱家还没条件
回复 支持 反对

使用道具 举报

[动态]还没有进行过任何战斗 (打开TA的战斗卡片)

Lv1.梦旅人

梦石
0
星屑
104
在线时间
1942 小时
注册时间
2013-11-2
帖子
1360
发表于 2014-8-18 19:53:54 | 显示全部楼层
感觉高大上?
话说我认识楼主吗?
回复 支持 反对

使用道具 举报

TA还没有解放自身的潜力。

Lv1.梦旅人

梦石
0
星屑
64
在线时间
171 小时
注册时间
2014-7-13
帖子
1567
发表于 2014-8-18 19:54:59 | 显示全部楼层
本帖最后由 柳泖 于 2014-8-18 05:56 编辑

好贵啊,FacLos你怎么看?
好吧,我游戏里用不到
Demon系列

在我面前颤抖吧,凡人
我走过我们人生的一半旅程,却又步入一片幽暗的森林,这是因为我迷失了正确的路径。啊!这森林是多么荒野,多么险恶,多么举步维艰!道出这景象又是多么困难!现在想起也仍会毛骨悚然。
回复 支持 反对

使用道具 举报

TA还没有解放自身的潜力。

Lv1.梦旅人

梦石
0
星屑
54
在线时间
1286 小时
注册时间
2011-6-14
帖子
4119
发表于 2014-8-18 20:06:11 手机端发表。 | 显示全部楼层
易语言略有过敏。
话说,RM本身就不支持Mac OS,你还写上没什么必要啊。
最讨厌做API还各种单词拼错还有大小写不分了。
还有,楼主我真的认识你吗……求原贴地址。

点评

基本上函数名都是全部拆分为单词然后翻译…………其实是可以使用中文函数名的,但是我就是喜欢作死…………  发表于 2014-8-20 16:07
Updata你确定是找度娘的?  发表于 2014-8-20 10:31
凑字数我会告诉你?还有…………API名称全部度娘不要找我…………  发表于 2014-8-19 16:13
回复 支持 反对

使用道具 举报

[动态]受到无双逗比侠的挑战,被揍得晕头转向。 (打开TA的战斗卡片)

Lv3.寻梦者

运否天赋

梦石
0
星屑
1053
在线时间
3187 小时
注册时间
2014-5-15
帖子
1515

开拓者

发表于 2014-8-18 20:12:31 | 显示全部楼层
表示关注
东京余烬demo开发中
回复 支持 反对

使用道具 举报

TA还没有解放自身的潜力。

Lv1.梦旅人

梦石
0
星屑
50
在线时间
444 小时
注册时间
2011-1-3
帖子
151

开拓者

发表于 2014-8-18 22:58:24 | 显示全部楼层
{:2_248:}没有简单的预览图吗。
收藏癖又犯了了.........Orz

点评

API能有什么预览图啊喂?貌似只有图标  发表于 2014-8-19 16:14
回复 支持 反对

使用道具 举报

TA还没有解放自身的潜力。

Lv1.梦旅人

梦石
0
星屑
54
在线时间
4352 小时
注册时间
2007-8-31
帖子
1982
发表于 2014-8-19 07:12:33 | 显示全部楼层
易语言写的吗?我觉得最好用C/C++这类写比较好
网络连接方面可以考虑增加个异步连接,也就是边玩边连接,这样就和网游比较像了

点评

伪网游,嗯,伪网游………………  发表于 2014-8-19 16:15
我真是王小二过年,一年不如一年。目前正在寻找状态中,努力找回当初的动力!
“底蕴制作者”—asperta最新博客开通!以后将在这里更新制作进度报告!
我的作品官网:http://www.asperta.org/
ASPERTA世界论坛:http://bbs.asperta.org/


回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册会员

本版积分规则

拿上你的纸笔,建造一个属于你的梦想世界,加入吧。
 注册会员
找回密码

站长信箱:fux2@moe9th.com|手机版|小黑屋|无图版|Project1游戏制作

GMT+8, 2019-6-17 09:13

Powered by Discuz! X3.1

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表